ic: website ic:blog
  ic: website Home · Archives · Photo Gallery · ic: forum RSS logo - thanks to www.nineteenlabs.comWeb feed (RSS)  
The life and times of james Hart: his family, his music, life in Luton and his occasional escapes onto the internet.

« Coffee with the Vobes at Monmouth Coffee House. | Main | Post-Christmas.. resolutions? »

Saturday, 20 December 2008

Missing calls on the Samsung i600 with a 3G SIM?

I've been having all kinds of problems with my phone since I got my Orange 3G SIM, especially in Central London. I'd find that texts would all come in at once, long after they'd been sent, along with messages about 'missed calls', despite the phone being on the whole time.

Since there are other ways to contact me at work (at least two other phone numbers!) I have been fairly sanguine about it, but when I was expecting a call on Thursday and it never came, I dialled '453' (the free service that tells pay-as-you-go users like me how much credit's left) and, after a long delay trying to connect, three text messages and a missed call notification came through.

My suspicion was that 3G was interfering somehow - or at least reducing the reliability of the phone - and this was borne out by the Orange customer services advisor, who suggested I switch to 2G/GSM operation for normal use (i.e. when I wasn't planning on making data calls).

In summary, then, the i600 on Orange gets very easily confused when both 2G and 3G services are available, and can get stuck in '3G' mode when it's not available; to avoid this, I need to go to the menus:

Start -> Settings -> Phone -> All Calls -> Band Selection

Normally, it'll be on AUTO - in a perfect world, this would happily choose between GSM and 3G (WCDMA). However, it seems that doesn't work, so I was advised to put it to GSM900/1800 for normal use (and that would perhaps also explain why it didn't work in Germany), and select AUTO when I'm surfing.

Whether this oddity is limited to (my!) Orange Samsung SGH-i600 on Orange with a 3G SIM, or extends to i600 on other services, or other Windows Mobile smartphones on Orange, I just don't know, but I thought it was worth sharing my experiences.

I know for a fact the 3G iPhone has had its share of problems with 3G, so perhaps it's simply that fast over-the-air data on mobile phones isn't quite mature yet...

Posted by james at December 20, 2008 3:24 PM

Comments

How odd, I used to have that problem on my old RAZR V3 on Virgin. I use the same SIM on my i600 and it is fine.

Posted by: Anonymous at December 20, 2008 5:00 PM

Post a comment




Remember Me?

(you may use HTML tags for style)


 
This site is owned and operated by Image Communications, including all content and stuff.
It's powered by Movable Type 4.25